English

Error: Cannot install ArcReader Service Pack

Error Message

The following error message displays when installing any of the ArcReader 9.x Service Packs:

"The upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. Verify that the program to be upgraded exists on your computer and that you have the correct upgrade patch."

Cause

ArcReader 9.x Service Packs cannot be installed on the same computer where an ArcGIS Desktop 9.x Service Pack is already installed. ArcGIS Desktop 9.x Service Packs include all the fixes included in ArcReader 9.x Service Packs, so it does not need to be installed separately.

ArcReader 9.x Service Packs are only for stand-alone installations of ArcReader 9.x.

Solution or Workaround

For computers that have both ArcReader and ArcGIS Desktop installed, install only the ArcGIS Desktop Service Pack.