English

FAQ: Do previous versions of ArcGIS need to be uninstalled before installing ArcGIS 9.3?

Question

Do previous versions of ArcGIS need to be uninstalled before installing ArcGIS 9.3?

Answer

Yes. Previous versions of ArcGIS 8.x and ArcGIS 9.x installs need to be uninstalled before installing any of the ArcGIS 9.x software. If the products conflict, a message displays during ArcGIS 9.3 installation and does not proceed until those products are removed.

Warning:
ESRI strongly recommends that all sample and third-party extensions be uninstalled before installing a newer version of ArcGIS.

To uninstall previous versions of ArcGIS:

a. In the Start menu, go to Settings > Control Panel > Add/Remove Programs.

b. Click 'Change' for the product to be removed; for example, ArcGIS Desktop.

c. Select 'Remove' to uninstall the previous version of ArcGIS.



Note:
An existing version of the ArcGIS License Manager does not conflict with ArcGIS and does not need to be uninstalled; however, the new ArcGIS 9.3 License Manager is required for using ArcGIS 9.3.

Note:
If the Enhanced Compression Wavelet (ECW) Plug-in is installed, uninstall it before uninstalling ArcGIS Desktop.

Note:
When preparing to upgrade the ArcGIS Desktop software, be sure to also uninstall Python and Pythonwin, located in Add/Remove Programs. ArcGIS Desktop installs a newer version of Python, and there are some incompatibility issues when multiple versions of Python are installed.

Related Information