English

Error: Could not edit the data in the folder or database selected. The current version does not support editing (base, consistent, or closed)

Error Message

When starting an edit session, the following error message is displayed:

"Could not edit the data in the folder or database you selected. The current version does not support editing (base, consistent, or closed)[Historical version are not editable.]"

Cause

The map document is currently pointing to a historical version.

Solution or Workaround

Use the 'Change Version' tool to point the map document to a transactional version.
[O-Image] Change version

Note:
When changing to a transactional version, be sure to select 'Transactional' and click a version name. If a transactional version name is not selected before clicking 'OK', the map document still points to a historical version.

  1. Click the 'Source' tab in the Table of Contents.
  2. Right-click the workspace that needs to have the version changed.
  3. Select 'Change Version'.
  4. Select 'Transactional' from the drop-down list.
  5. Click on the transactional version to be edited.
  6. Click 'OK'.
  7. Start editing.

Related Information