English

How To: Export a 3D shapefile to DXF format and keep elevation values

Summary

Instructions provided demonstrate how to convert a 3D shapefile to DXF format.

Note:
The shapefile must have features identified as "Z" or "ZM" listed as the feature type in the SHAPE field of the attribute table.


Note:
The instructions in this article apply only to ArcGIS Desktop 9.3.1 and previous versions.

Procedure

The 3D shapefile must contain a field named 'elevation', defined as a Long Integer field, with a precision of 9. A field named 'elevation' can be added to the shapefile in ArcCatalog through the shapefile properties, by right-clicking the shapefile and selecting Properties > Fields tab. The 'elevation' field can also be added to the shapefile in ArcMap. Elevation values can be calculated into the field using the Field Calculator in ArcMap.
<a href='http://support.esri.com/en/knowledgebase/techarticles/detail/19643' target='_blank'>How To: Calculate X, Y, and Z values in an attribute table using Field Calculator</a>

  1. Add the ArcView 8.x Tools to ArcCatalog by selecting Tools > Customize > Toolbars tab, and checking ArcView 8.x Tools. Dock the 'Conversion Tools' toolbar in ArcCatalog.
  2. In ArcCatalog select Conversion Tools > Shapefile to DXF.
    Warning:
    The Shapefile to DXF Tool will fail if:
    1. There are spaces in the path to the input shapefile, or to the output DXF file.
    2. There is a directory name in the path to the input shapefile or output DXF file longer than 8 characters.
    3. The shapefile is in a folder named TEMP.
    4. The input shapefile or output DXF file are over a network. Both the input shapefile and output DXF file locations must be on the local hard drive.


    Note:
    The default of 0 decimal places is accepted in the tool. Esri suggests three or four decimal places for the output.

  3. To view the output data in AutoCAD, select View > Zoom > Extents.

    Note:
    This conversion process creates BLOCK entities in the output DXF file. The output feature color is black, and the default draw canvas color in AutoCAD is also black. To improve data visibility, either change the draw canvas color in AutoCAD to white, or select all features from the output DXF file in AutoCAD, explode the blocks and change the draw color for the selected features.