English

Problem: Route Server 9.1 fails with ArcIMS 9.1 Service Pack 2

Description

ArcIMS 9.1 Service Pack 2 is currently not certified for use with Route Server 9.1.

With ArcIMS 9.1 SP2 installed, Route Server 9.1 fails to start and the following error message is returned in the Application Server log:

<ERROR code="1" numthreads="0" >
library can not be loaded : C:\Program Files\ArcGIS\ArcIMS\Server\ext\RouteServer\RouteServer.dll
</ERROR>

Cause

Updates made to aimscsys.dll in ArcIMS 9.1 SP2 causes the Route Server to fail during initialization.

Solution or Workaround

If using Route Server, do not install ArcIMS 9.1 Service Pack 2. Wait for an updated version of Route Server for ArcIMS 9.1 Service Pack 2.

If ArcIMS 9.1 Service Pack 2 is already installed, uninstall it. This can be done by one of the two options below:

  • Restore a previously installed version from a backup.
  • Completely reinstall ArcIMS to enable Route Server to work correctly.