English

Bug: Error: 'Cannot determine DBMS release' when running sdesetupora9i with Oracle 10g R2

Description


Note:
This issue is addressed in ArcSDE 9.1 Service Pack 1 (SP1).

When running sdesetupora9i -o install -u SDE -p xxxxx
for ArcSDE 9.1 for Oracle 10g R2, the following error may get returned:

ESRI ArcSDE Server Setup Utility
----------------------------------------------------------------
db_get_dbms_release:: Invalid Release (10.2.0.1.0)
Cannot determine DBMS release using SDO_ADMIN.sdo_version function.

Cause

ArcSDE 9.1 is not supported with Oracle 10g R2. There is a known issue that prohibits it from connecting to Oracle 10g R2 databases.

Workaround

A fix included in ArcSDE 9.1 Service Pack 1 will allow the connection. Download the pack using the link in Related Information, below.

    Related Information