English

Problem: MOLE 9.1 Installation conflict with ArcWeb Toolbar

Description

If the ArcWeb Services toolbar is installed before MOLE, the following error may occur when trying to install MOLE:

"Military Overlay Editor requires 9.1 or higher version of ArcGIS Desktop, ArcGIS Engine Runtime, ArcReader, ArcIMS ArcMap Server or ArcGIS Server to continue."

Cause

This happens when the ArcWeb services toolbar version 1.1 is installed prior to installing MOLE 9.1. The installation of the ArcWeb toolbar is replacing the ArcGIS 9.1 coreRuntime hives with 9.0 characters. When MOLE runs, it expects ArcGIS 9.0 is installed.

Solution or Workaround

Edit the coreRuntime key in the Windows registry editor:

Warning:
The steps below include making changes to essential parts of your operating system. It is recommended you backup your operating system and files, including the registry, before proceeding. Consult with a qualified computer systems professional, if necessary. ESRI cannot guarantee results from incorrect modifications while following these instructions. Therefore, use caution and proceed at your own risk.

  1. Click Start > Run, type regedit and click OK.
  2. In the Registry Editor, navigate to My Computer\HKEY_LOCAL_MACHINE\SOFTWARE\ESRI\CoreRuntime key.
  3. In the left pane of the Registry Editor window, highlight the CoreRuntime key.
  4. In the right-hand pane, right-click the RealVersion key, then click Modify. On the Edit String dialog box, in the Value data text box, change '9.0.0.0' to '9.1', then click OK.
  5. In the right pane, right-click the InstallVersion key, then click Modify. On the Edit String dialog box, in the Value data text box, change '9.0.0.0' to '9.1.0.0', then click OK.
  6. Close the Registry Editor and start the MOLE installation wizard again.

Related Information