PROBLEM

Installation of ArcGIS Desktop 'freezes' on rastersde8x.dll

Last Published: January 4, 2021

Description

When installing ArcGIS, the installation may 'freeze' or stop responding while registering the file rastersde8x.dll.

Note:
This article pertains to ArcGIS versions 9.x only. Later versions of ArcGIS may contain different functionality, as well as different names and locations for menus, commands and geoprocessing tools.

Cause

There are conflicting entries present in the registry.

Solution or Workaround

After removing any ArcGIS products, and before attempting to install ArcGIS, remove the conflicting Raster entries in the registry.

  1. Open regedit by way of Start > Run; type 'regedit'.
  2. Browse to HKEY_LOCAL_MACHINE\Software\ESRI\
  3. Delete the \Raster hive. This removes the conflicting registry entries.
  4. Reinstall ArcGIS normally. The problem should no longer occur.

Article ID:000008146

Software:
  • ArcMap 9 x

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Discover more on this topic