English

Error: System requirements check shows status of FAILED when installing ESRI 9.1 products on Solaris 10 platform.

Error Message

Installing the following ESRI 9.1 products on a Solaris 10 operating system may display a warning message in the log file:

- ArcGIS Server 9.1 for Sun Solaris
- ArcIMS 9.1 for Sun Solaris, with the ArcMap Server extension
- ArcReader 9.1 for Sun Solaris
- ArcGIS Engine Runtime 9.1 for Sun Solaris
- ArcGIS Engine Development Kit 9.1 for Sun Solaris

The error message is similar to the following example, displayed with installation of ArcIMS 9.1 for Sun Solaris:

"ArcIMS Setup has detected that your system may not meet system requirements.
If system requirements are not satisfied, ArcIMS may not install correctly.

View the following log file for details regarding system requirements.

Log File: $HOME/MWSysReq.log

The log will state:
Product: OS Version : OSComp : 5.10 : 2.6 || 7 || 8 || 9 : [FAILED]"

Cause

These ESRI products on the Sun Solaris platform require a third-party product called Visual MainWin. Visual MainWin is installed automatically, and installation includes verifying that the system meets the Visual MainWin system requirements. The utility that checks the environment for the Visual MainWin product in the 9.1 release does not recognize the Solaris 10 operating system and generates the error.

Solution or Workaround

The error can safely be ignored. Verify that there are no other failure messages in the log file. If there are no other failures, proceed with the install.

After installation the products are fully supported on the Sun Solaris 10 operating system.