PROBLEM

ColdFusion conflict with the ArcIMS servlet engine

Last Published: April 25, 2020

Description

If ArcIMS and ColdFusion MX are installed on the same machine, the HelloWorldExample or the TestServlet tests may work, but the ArcIMS Diagnostic tests may fail with errors.

The specific errors may vary, but the messages typically contain ColdFusion or JRUN related text and/or an HTTP 404 "Page Cannot Be Found" error.

Cause

ColdFusion MX runs an internal JRUN servlet engine, which may interfere with the Tomcat or ServletExec servlet engine used by ArcIMS.

Solution or Workaround

Disable ColdFusion's internal JRUN servlet engine from handling requests meant for the ArcIMS servlet engine.

  1. Edit the following file:
    <ColdFusionMX-Directory>\runtime\servers\default\SERVER-INF\default-web.xml

    Note:
    For ColdFusion MX7, the path is as follows:
    <ColdFusionMX-Directory>\runtime\servers\coldfusion\SERVER-INF\default-web.xml

  2. Locate the following code:

    Code:
    <servlet-mapping>
    <servlet-name>ServletInvoker</servlet-name>
    <url-pattern>/servlet/*</url-pattern>
    </servlet-mapping>

  3. Comment out the servlet-mapping code by adding "<!--" at the beginning of the code and "-->" at the end. For example:

    Code:
    <!--
    <servlet-mapping>
    <servlet-name>ServletInvoker</servlet-name>
    <url-pattern>/servlet/*</url-pattern>
    </servlet-mapping>
    -->

  4. Save and close the file.
  5. Restart the ColdFusion Application Server.

Article ID:000007948

Software:
  • Legacy Products

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