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Error: Inconsistent data type in GEOMETRY_COLUMNS table

Error Message

The following error may occur when attempting to start the ArcSDE Application Server for ArcSDE 9.x for Oracle:

>sdemon -o start
esri_sde service failed during initialization.
Please check event log or error log files.
Error starting esri_sde service(997)
Could not start ArcSDE -- Check Network, $SDEHOME disk, DBMS settings and
dbinit.sde.

The SDE error log file in $SDEHOME/etc may contain the following error:

-------------------------------------------------------
ArcSDE 9.0 Oracle9i Build 1093 Fri Mar 19 13:28:50 PST 2004
-------------------------------------------------------
db_get_dbms_release::Current Release 9.2.0.4.0 is assumed to be compatible with 9.0.0.0.0
Instance initialized for SDE . . .
Connected to instance . . .
Inconsistent data type in GEOMETRY_COLUMNS table.

Cause

This error can occur if an upgrade to the Oracle software on the RDBMS server was not completely successful, for example an upgrade from Oracle 9.2.0.0 to Oracle 9.2.0.5.

This error can also occur if the Oracle software was upgraded successfully, but the required upgrade of the Oracle database following the software upgrade was either omitted or not completed successfully.

Solution or Workaround

Reapply the Oracle software upgrade and/or redo the database upgrade procedures as required to make sure that the both the software upgrade and the database upgrade were successful. Consult the Oracle documentation or contact Oracle Technical Support if assistance is required.

This error can also occur with fresh installations of Oracle and ArcSDE during ArcSDE's Post-Installation procedures when it attempts to start the Application Server for the first time. For these cases, the following procedure should resolve the problem:

  1. Drop the Oracle database.
  2. If ArcSDE is running on a Windows platform, perform the following step. Otherwise, proceed to step 3.

    Delete the ArcSDE service using the sdeservice -o delete command. Refer to the ArcSDE Developer Help for information on the usage of this command.
  3. Reapply the Oracle software upgrade.
  4. Build a new Oracle database.
  5. Run the ArcSDE Post-Install procedure as described in the ArcSDE Installation Guide for your server platform.