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Bug: The Post Install hangs after entering the username and password for the Windows Services dialog box

Description

After installing a service pack for ArcIMS 9.0, the Post Install hangs after entering the username and password for the Windows Services dialog box.

Cause

This is caused when ArcIMS is unable to delete and recreate the Windows Services correctly.

Subsequently, the Application Server Service is missing in the Windows Service panel. It is also removed from the Registry under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services.

If the Post Install is run again, it will always hang on this screen and never re-create the Application Server Service.

Workaround

Warning:
WARNING: The instructions below include making changes to essential parts of your operating system. It is recommended that you backup your operating system and files, including the registry, before proceeding. Consult with a qualified computer systems professional, if necessary.

ESRI cannot guarantee results from incorrect modifications while following these instructions. Therefore, use caution and proceed at your own risk.

  1. Start the Registry editor. Navigate to Start > Run, type regedit and click OK.
  2. Expand HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services.
  3. Find the entries for 'ArcIMS Monitor 9.0' and 'ArcIMS Tasker 9.0' and delete them.
  4. Re-run the ArcIMS Post Installation. All three services should be re-created.

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