English

Bug: Java Viewer is blank or shows a "No JDK 1.3 Support for APPLET!!" error message

Description

At ArcIMS 9.1, the Java Viewers do not automatically prompt for a download of the Java 2 Runtime Environment (JRE). Instead of prompting for the download, the Java Custom Viewer shows the error message: "No JDK 1.3 Support for APPLET!!"

The Java Standard Viewer shows a blank screen.

Cause

The ArcIMS 9.1 Java Viewers have a known issue that prevents them from triggering the automatic download of the required Java 2 Runtime Environment.

Workaround

Before using the Java Viewers, install a supported version of the Java 2 Runtime Environment on the client machine. For example, JRE 1.4.2_06 is supported for use with ArcIMS 9.1.

The JRE 1.4.2_06 install package can be downloaded from http://java.sun.com/products/archive/j2se/1.4.2_06/index.html

    Related Information