English

Bug: Maps exported to PNG and/or GIF do not have a transparent background or the background is the same color as the Windows background

Description


Note:
This issue is addressed with ArcGIS 9.1 Service Pack 2 (SP2).


Maps exported from ArcMap to either the PNG or GIF format do not have a transparent background even if the background was set to no data. The background displays either as white or the same color as the Windows background.

Cause



This is a known issue.

Workaround

Note:
This issue is addressed with ArcGIS 9.1 Service Pack 2 (SP2).

Download the Service Pack from the link in Related Information section below, or use the following procedure to work around this issue in either ArcGIS Desktop 9.0-9.1 Service Pack 1.

Note:
If the problem continues after installing 9.1 SP2, ensure that the Background Color and Transparent Color are set correctly, as described in steps 7 and 8 below.

  1. Close ArcMap and ArcCatalog if they are open.
  2. Right-click on the Windows desktop and select Properties.
  3. On WindowsXP, select the Appearance tab, click the the Effects button and uncheck 'Use the following method to smooth edges of screen fonts' if it is checked on.

    On Windows 2000, select the Effects tab and uncheck 'Smooth edges of screen fonts' if it is checked on.

    Note:
    It is a known limitation of the ArcGIS 9.1 Service Pack 1 that screen font smoothing is not supported for exporting from ArcMap to PNG or GIF with transparent backgrounds. This has been fixed in ArcGIS 9.1 Service Pack 2.

  4. Start ArcMap, open the map to export to PNG or GIF and navigate to File > Export Map.
  5. Click the Save as Type drop-down and select either PNG or GIF.
  6. On the Format tab, click the Color Mode drop-down and select either '8-bit Palette' or '8-bit Grayscale'.

    Note:
    Transparency is not supported with 24-bit True-color PNG or GIF exports at ArcGIS 9.1 Service Pack 1. This has been fixed in ArcGIS 9.1 Service Pack 2.
  7. Click the Background Color drop-down chip. Select a color not used in the map; for example, bright magenta.
  8. Click the Transparent Color drop-down and select the same color as used in step 7.
  9. Click Save to export the map.

Related Information