English

How To: Convert a raster dataset to an XYZ table

Summary

Several software packages can import data from an XYZ format. Information provided describes converting a raster dataset into an XYZ table for that purpose. This process requires a Spatial Analyst license.

Procedure

  1. Open ArcMap and add the raster dataset.
  2. Open the Sample tool from ArcToolbox > Spatial Analyst Tools > Extraction > Sample.
  3. Select the raster dataset as the Input Rasters.
  4. Select the raster dataset again in the Input location raster or point features field.
  5. Make sure Resampling technique is set to NEAREST.
  6. Specify an output table.
  7. Click OK.
  8. Open the new table in ArcMap.
  9. Select Options > Export.
  10. Set Export to All records.
  11. Click the browser button next to the Output Table field.
  12. Set Save As Type to Text File and set an output location and filename.
  13. Click Save.
  14. Click OK on the Export Data menu.
  15. The output text file is in the following format:
    OID, Z, X, Y
    The following is an example of the output file:
An image of the output table of the Sample tool
  1. Use a spreadsheet program such as Microsoft Excel to rearrange the columns as necessary.

Related Information