PROBLEM

Low disk space on an ArcIMS server

Last Published: April 26, 2020

Description

After some time of using ArcIMS, the disk space of the ArcIMS server may decrease and map services may fail to start because the disk space is low.

Cause

When creating ArcMap image services, temporary files are written but are only used for a few seconds during the map service creation or if the ArcIMS server is stopped and restarted. Because these temporary files are not automatically removed can fill available disk space and be a cause for map services start failure.

Solution or Workaround

Set up the ArcIMS Tasker service to clean these files up in a specified interval, for example after, 15 minutes:
  1. Navigate to <installation directory>\ArcGIS\ArcIMS\AppServer\Tasker and open the file tasks.xml in a text editor.
  2. Add the following line (edit the path to point to the corresponding location on your machine):
    Code:
    <CLEANUP dir="C:/Program Files/ArcGIS/ArcIMS/Server/tmp" exts="mxd" interval="15" /> 
    Note:
    The path to the temporary directory may be different on your machine.
    
    Instructions provided describe how to edit environment variables for various platforms. See: How To: Edit an environment variable
  3. Open the file tasker.properties in a text editor, and make sure the following line is uncommented, and points to the tasks.xml file edited in Step 1:
    Code:
    taskFile=C:/Program Files/ArcGIS/ArcIMS/AppServer/Tasker/Tasks.xml
  4. Restart the ArcIMS Windows Services Application Server, Monitor and Tasker.
    Now the temporary *.MXD files should get cleaned up automatically.
    Note:
    Tasker can also remove other files on a regular basis.

Article ID:000007681

Software:
  • Legacy Products

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