English

Error: Error adding element

Error Message

In ArcGIS 9.0 or later, when creating or editing annotation features or simple features with related feature-linked annotation in a personal geodatabase with a version of 8.3 or older, the following error message displays:

"Error adding element. The edit that you have made is not supported in earlier versions of the Geodatabase".

Cause

Annotation was significantly updated at ArcGIS 9.0. Due to this update, annotation editing of previous geodatabase versions was blocked to prevent the creation of annotation incompatible with previous versions of the software.

Solution or Workaround

Upgrade the personal geodatabase, so that the geodatabase version matches the ArcGIS version currently running.

  1. For more information on how to upgrade the geodatabase, see the ArcGIS Desktop help topic 'Upgrading a geodatabase.'

    Warning:
    It is not possible to view any of the data with an earlier version of ArcGIS if the geodatabase is upgraded to a current version.