BUG

ArcGIS License Manager processes jump to 100% CPU utilization when Nessus or other port scanners are used to scan the network

Last Published: January 21, 2021

Description

Note:
This article pertains to ArcGIS versions 9.x only. Later versions of ArcGIS may contain different functionality, as well as different names and locations for menus, commands and geoprocessing tools.

When the network is scanned by Nessus or other port scanners, the ArcGIS License Manager gradually or suddenly increases CPU utilization to 100%.

Cause

Nessus is a port scanner that is used to evaluate network security. In the process of scanning all ports, Nessus may interrupt communications between ArcGIS License Manager and its clients. As a result, the lmgrd and ArcGIS processes may stop responding and cause CPU utilization to jump to 100%.

Workaround

Configure the license manager to utilize a static second TCP port, instead of the default dynamic port. The Nessus scan can then be configured to skip both of the ports and eliminate the problem. Refer to How to: Lock the vendor daemon to a specific port for more details on this configuration change and which ports to open.

Article ID:000007102

Software:
  • ArcMap 9 x

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