ERROR

1022: Your machine's IP address has changed. Please reconnect to ArcWeb Services

Last Published: April 26, 2020

Error Message

When attempting to connect to ArcWeb Services using the ArcWeb Toolbar, the following Microsoft .NET Framework error appears:

Error:   
An unhandled exception has occurred in a component in your application. Click continue and the application will ignore this error and attempt to continue.

"1022: Your machine's IP address has changed. Please reconnect to ArcWeb Services."

Cause

This error message occurs if ArcWeb Services detects different IP addresses in requests. There are two possible causes for this:

  • The machine's IP address has changed since the last time the user connected to ArcWeb Services with the ArcWeb Toolbar.
  • The proxy server or firewall uses a different IP addresses for HTTP requests than it does for HTTPS requests.

Solution or Workaround

The solutions listed here correspond with the potential causes listed in the previous section.
  • If the IP address has changed since the last time the user connected to ArcWeb Services using the ArcWeb Toolbar:
  1. Close ArcMap if it is currently open.
  2. Download and install the Toolbar patch from the ESRI Support Center.
  • If the proxy server or firewall uses a different IP address for HTTP requests than it does for HTTPS requests:
  1. Close ArcMap if it is currently open.
  2. Remove the ArcWeb connection token value from the Windows registry.
Warning:   
The instructions below include making changes to essential parts of your operating system. It is recommended that you backup your operating system and files, including the registry, before proceeding. Consult with a qualified computer systems professional, if necessary.

ESRI cannot guarantee results from incorrect modifications while following these instructions. Therefore, use caution and proceed at your own risk.
  1. Open the Registry Editor. To do so, click Start Run, and type regedit in the Open field.
  2. In the registry window, navigate to HKEY_CURRENT_USER\Software\VB and VBA Program Settings\ESRI\ArcWeb Toolbar.
  3. Double-click token. An edit string dialog box appears.
  4. Delete the character string in the Value field and click OK.
  5. Close the registry window.
  1. Open ArcMap.
  2. Open the Connect to ArcWeb Services dialog box.
  3. Click the Options button and check the Use HTTPS for all ArcWeb requests check box.
  4. Enter the user name and password and click OK to connect to ArcWeb Services.

Article ID:000007047

Software:
  • Legacy Products

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