English

How To: Increase the number of records in a spreadsheet that is added to a layout

Summary

Instructions provided explain how to add more records to an Excel spreadsheet than are added to a layout.

Procedure

  1. Open the spreadsheet in Excel and adjust the font to the desired size.
  2. Select the records that should be included in the layout (if all records are needed then select Edit > Select All). Once the appropriate records are selected click Edit > Copy.
  3. In Page Layout view in ArcMap, select Insert > Object > Create New > Microsoft Excel Worksheet. Click OK.
  4. Paste the contents of the original spreadsheet into the new, blank workbook provided. As soon as data is added to the new worksheet, it is visible in ArcMap.

    Note:
    The limit of records that can be added to a spreadsheet and are visible in a layout vary. Results are dependent on the font and size of the tabular data as well as the size of the page.

  5. The new workbook can be closed (without saving) after the paste is complete. It is saved within the map document.

    These steps can be repeated to add additional spreadsheet objects to the layout.
    Note:
    To append data to spreadsheets that have already been added to ArcMap as objects, double-click on the spreadsheet in layout. This opens the spreadsheet in Excel and allows edits to be made.