English

FAQ: Can ArcSDE 8.3 raster layers be connected to from ArcIMS 4.0.1 with QFE Spatial Server Image Server Update or ArcIMS 9.0?

Question

Can ArcSDE 8.3 raster layers be connected to from ArcIMS 4.0.1 with QFE Spatial Server Image Server Update or ArcIMS 9.0?

Answer

Yes, a three tier connection using the ArcSDE server is possible.

There is one difference; for a vanilla ArcIMS 4.0.1 server, Administrator adds an AXL with raster name specified with mixed case in the DATASET tag.

Code:
<SDEWORKSPACE name="sde_ws-0" server="zephyr" instance="sde:oracle" database="TEST" user="FUN" encrypted="false" password="FUN" />
</WORKSPACES>
<LAYER type="image" name="hillshade" id="hillshade" visible="false" >
<DATASET name="FUN.hillshade.image" type = "image" workspace="sde_ws-0" />

However, if ArcIMS 4.0.1 is used with the latest ArcIMS 4.0.1 QFE Spatial Server - Image Server Update an error occurs.
[O-Image] Error


If an attempt to add the AXL file to Administrator in ArcIMS 9.0 the following returns:
[ERRO125] & [ERRO930].

To resolve this, specify the name in DATASET in uppercase.

Code:
<SDEWORKSPACE name="sde_ws-0" server="zephyr" instance="sde:oracle" database="TEST" user="FUN" encrypted="false" password="FUN" />
</WORKSPACES>
<LAYER type="image" name="hillshade" id="hillshade" visible="false" >
<DATASET name="FUN.HILLSHADE.IMAGE" type = "image" workspace="sde_ws-0" />


Note:
For ArcIMS 9.0 the licensing has been changed so a Direct Connect to an ArcSDE 8.3 database cannot be used.

Upgrade ArcSDE 8.3 to 9.0 to verify these instructions work.

Related Information