English

Bug: Performing a refresh in a Java Custom Viewer using J2SE JRE 1.4.2 or 1.4.2_06 may cause the browser to crash

Description

ArcIMS Java Custom Viewer may crash when using the browser's Refresh button on a machine with Java 2 Runtime Environment, Standard Edition 1.4.2 or 1.4.2_06 (J2SE JRE)

Cause

This is a known issue with J2SE JRE 1.4.2 and 1.4.2_06

Workaround

The ArcIMS Java Viewer requires the installation of a Java Runtime Environment (JRE). By default, the Java Viewer will always run using the latest version of the JRE installed on the client machine. If a client machine does not have a JRE installed when accessing the Java Viewer for the first time, you will be prompted to install it prior to loading the Java Viewer applet. With ArcIMS 9.0, the JRE install that gets launched by default is J2SE JRE v.1.4.2 and with ArcIMS 9.1 it is 1.4.2_06. If these JRE are used with a Java Custom Viewer it causes the browser to crash when using the Refresh button.

For Users:
1. Cancel the JRE 1.4.2/1.4.2_06 install if prompted when launching a Java Custom Viewer Web site.
2. Install a different J2SE JRE version. Supported J2SE JRE versions that don't have this known limit with the browser Refresh are: 1.4.0 and 1.4.1_02. Get these versions from the Sun Java Web site at http://java.sun.com/products/archive/.

For Developers:
1. Download a different JRE version and place it in the install directory where your Web sites reside, such as C:\ArcIMS\Website\install. Supported J2SE JRE versions that don't have this known limit with the browser Refresh are: 1.4.0 and 1.4.1_02. Get these versions from the Sun Java Web site at http://java.sun.com/products/archive/.

2. For each created Java Custom Viewer Web site edit the following line in /ArcIMS/Website/<Website_Name>/ie.htm file as per your ArcIMS Version, downloaded JRE version and file name.

Code:
codebase = new String(array[0] + "//" + array[2] + "/website/install/j2re-1_4_2-windows-i586.exe #Version=1,4,2");

E.g., if you downloaded JRE v.1.4.0, for ArcIMS 9.0 edit the line to look like this:

Code:
codebase = new String(array[0] + "//" + array[2] + "/website/install/j2re-1_4_0-windows-i586.exe #Version=1,4,0");


This will prompt the client to install a JRE version only if the client machine does not have a JRE greater than 1.3.1 already installed.

3. If you want to force the ArcIMS Java Viewer Applet to run using a specific version of the Java Plug-In then refer to the corresponding article in Related Information, below.

Related Information