English

FAQ: Are ArcSDE 8.3 and DB2 Spatial Extender Version 8.1 compatible?

Question

Are ArcSDE 8.3 and DB2 Spatial Extender Version 8.1 compatible?

Answer

In DB2 UDB Version 8.1, significant enhancements were made to the Spatial Extender's system catalog tables. Due to the enhancements, existing users of the ESRI ArcSDE for DB2 middleware product could not upgrade from DB2 UDB Version 7.2 to DB2 UDB V8.1, and new customers were limited to DB2 UDB V7.2.

The SQL Data Definition Language (DDL) scripts available for download from this page can be used to restore compatibility between the ESRI ArcSDE 8.3 middleware product and DB2 UDB V8.1.

The ZIP file available through the download link in Related Information below contains the following files:

Readme.1st
sdedbsetup.clp
sdesetup1.clp
sdesetup2.clp
sdemigrate.clp

Instructions are provided in the Readme.1st file for applying the DDL scripts in two scenarios:

1. New customers who are installing ArcSDE 8.3 and DB2 UDB V8.1 together for the first time
2. Existing ArcSDE 8.3 customers who need to migrate their DB2 UDB V7.2 instance to V8.1

Related Information