ERROR

The system cannot find the file specified. C:\documents and settings\username\aimsdefaults.properties

Last Published: April 25, 2020

Error Message

During the ArcIMS 4.0.1 Post Installation, after entering the Web site and Output directory location, the following error message occurs:

"The system cannot find the file specified. C:\documents and settings\username\aimsdefaults.properties"

Cause

The file aimsdefaults.properties located in the default location c:\program files\arcgis\arcims\common has been edited and was saved incorrectly with the wrong extension, e.g. aimsdefaults.properties.txt.

The error message is misleading, as the setup simply cannot copy the original file to the mentioned target location.

Solution or Workaround

The file aimsdefaults.properties located in the \common folder gets edited by the ArcIMS Post Installation and then copied to the user's profile. The original file should not be changed. To fix the problem, follow these steps:

  1. Copy the following text into Notepad and save it as "aimsdefaults.properties" including the quotes, under the <install location>\ArcIMS\Common folder replacing the corrupt existing file:
    Code:
    ##
    # ArcIMS v4.0.1 Site Properties Settings
    ##
    #UserName - Login for the ArcIMS Administrator
    #HostName - Full name of the host machine. The full name of the host machine may mean
    # including the domain name. For UNIX users, you will need to include the domain name.
    #HostALIAS - Alias of the host machine
    #HostURL - URL of the host machine
    #WorkingDir - Default working directory, where map configuration files are stored
    #WebSiteDir - Default web site directory, where created sites are stored
    #ImagePath - Path to the image output directory
    #ImageURL - URL for image output (Using HostURL)
    #Scavenger - Scavenger cleanup interval in minutes
    #IndexBuilderEXE - Path of the geocoding index builder (aimsindxb.exe)
    #WebBrowser - Location of default web browser (required for OnLine Help)
    #WebBrowser.usesQuotes - Netscape 6 users must switch this value to true
    #ArcIMSHelp - Main HTML page for ArcIMS OnLine Help
    #ImageMemory - Amount of memory to reserve for Spatial Server images
    #MaxImageMemory - Maximum Image memory Limit allowed in Megabytes
    #ForceAddServers - Upon launching of ArcIMS Manager, if "true", a default server is added
    # to each monitors with no servers associated with it; if "false", no servers are added
    ##
    ImageURL=http\://ARCIMSHOST/output
    ImagePath=C\:/arcIMS/output
    HostName=ARCIMSHOST
    HostALIAS=ARCIMSHOST
    HostURL=http\://ARCIMSHOST
    Scavenger=10
    UserName=admin
    WebSiteDir=c\:/ArcIMS/Website
    WorkingDir=c:\:/ArcIMS/AXL
    IndexBuilderEXE=C\:\\Program Files\\ArcGIS\\ArcIMS\\IndexBuilder\\aimsindxb.exe
    WebBrowser=C\:/Program Files/Plus!/Microsoft Internet/iexplore
    WebBrowser.usesQuotes=false
    ArcIMSHelp=C\:/Program Files/ArcGIS/ArcIMS/Manager/Help/arcims_help.htm
    ImageMemory=4
    MaxImageMemory=250
    ForceAddServers=false


  2. Run the Post Installation to configure ArcIMS correctly.
  3. If you want to change the file manually, please edit C:\Documents and Settings\<user_name>\aimsdefaults.properties. Do not edit the original file.

Article ID:000006390

Software:
  • Legacy Products

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Discover more on this topic