ERROR

Component crviewer9.dll or one of its dependencies not registered correctly

Last Published: April 25, 2020

Error Message

While using Crystal Reports 9.0 and ArcMap, you may receive an error:

"Component crviewer9.dll or one of its dependencies not registered correctly".

Cause

This is a known issue.

Solution or Workaround

Uninstall and reinstall Crystal Reports 9.0.

  1. Uninstall Crystal Reports 9.0.

    A. Clicking Start > Settings > Control Panel.

    B. Double-click Add/Remove Programs.

    C. Click Crystal Reports for ESRI > Remove > Remove All > Next > Finish.


  2. Reinstall Crystal Reports 9.0:
    Insert the Crystal Reports 9.0 CD in the CD-ROM drive and follow the onscreen installation instructions.

Article ID:000005872

Software:
  • ArcMap 8 x
  • ArcMap 9 x

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Discover more on this topic