PROBLEM

Process freezes when loading data into a personal geodatabase

Last Published: April 25, 2020

Description

When loading data into a personal geodatabase from ArcCatalog or ArcToolbox the process comes to a halt.

Cause

This can happen when the MaxLocksPerFile parameter is exceeded. This is a MicroSoft Jet registry setting that limits the number of records which can be edited in an Access database.

Solution or Workaround

Increase the value of the MaxLocksPerFile registry key.
Warning:
The instructions below include making changes to essential parts of your operating system. It is recommended that you backup your operating system and files, including the registry, before proceeding. Consult with a qualified computer systems professional, if necessary.

Esri cannot guarantee results from incorrect modifications while following these instructions; therefore, use caution and proceed at your own risk.

1. Exit all open ArcGIS applications.

2. Run the Advanced Settings executable.

  • In ArcGIS 8.1, run AdvAMSet.exe, located under \ArcObjects Developer Kit\Utilities\VBAdvancedSettingsUtility in your install directory.
  • In ArcGIS versions 8.1.2 and later, run AdvancedArcMapSettings.exe, located under \arcexe81\Utilities. At this version, the utility has a slightly different look than the image below.

[O-Image] Example

3. Click the Editor tab.

4. Update the 'Jet Engine max # of records to calculate' value. Choose a number slightly greater than the number of records in the data.

5. Open ArcCatalog or ArcToolbox and try loading the data again.

Article ID:000005688

Software:
  • Legacy Products

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