English

FAQ: Are ArcIMS applications forward compatible with major new releases of ArcSDE?

Question

Are ArcIMS applications forward compatible with major new releases of ArcSDE?

Answer

ArcIMS applications are not forward compatible with major new releases of the ArcSDE server product and the Geodatabase. This means that older versions of ArcIMS are not tested, certified nor supported with newer major releases of ArcSDE. Unlike ArcGIS Desktop, ArcIMS does not have a check of the version of the Geodatabase nor of the version of ArcSDE. It may be possible to connect to and use a newer version of ArcSDE. ESRI is not able to offer support for this configuration.

Examples of migrating to major releases of ArcSDE are:
- ArcSDE 8.0.x to 8.1.x
- ArcSDE 8.1.x to 8.2.x

When upgrading ArcSDE between such versions, it is required that ArcIMS also be upgraded to a compatible version.
- Migrating ArcSDE 8.0.x to 8.1.x requires that ArcIMS be migrated to ArcIMS 3.1.
- Migrating ArcSDE 8.1.x to 8.2.x requires that ArcIMS be migrated to ArcIMS 4.0.x.

ESRI understands that many of our customers require a phased upgrade path. The ArcIMS client application suite is backward compatible with older versions of ArcSDE. This allows ArcIMS to be upgraded first. Note that this does not give ArcIMS access to features that are only available in the newer version of ArcSDE.