English

Problem: UNIX scripts for managing ArcIMS servers and services do not work after upgrade to 4.0 or 4.0.1

Description

On UNIX ArcIMS services and servers can be managed using the command line. This is implemented using scripts. After upgrading from ArcIMS 3.x to 4.x, the scripts previously used no longer work correctly.

Cause

Two of the Java Archive (JAR) files used in the UNIX scripts for managing ArcIMS servers and services have changed names in ArcIMS 4.0 and 4.0.1.

Solution or Workaround

After upgrading, modify the scripts for use with ArcIMS 4.0 and 4.0.1.

  1. Open the script in a text editor.
  2. Find

    $JARHOME/arcims_sdk.jar

    and replace it with

    $JARHOME/esri_mo10.jar

  3. Find

    $JARHOME/arcims_ressdk.jar

    and replace with

    $JARHOME/esri_mo10res.jar

  4. Save and close the script.

Related Information