English

FAQ: What versions of ArcGIS support the display of ArcIMS map services?

Question

What versions of ArcGIS support the display of ArcIMS map services?

Answer

ArcGIS 8.2, 8.3, 9.0 and above support ArcIMS map services (ArcIMS version 4.x or above). ArcGIS 8.1.2 (Build 671) also works, provided that the msxml3.dll is present and registered on the client machine. Obtain the msxml3.dll by upgrading to Internet Explorer 6, or click on the link 'Microsoft XML Parser' in Related Information below.

Older versions of ArcGIS are not supported clients for ArcIMS.

Register the DLL. Please note the following warning for this procedure:

Warning:
The instructions below include making changes to essential parts of your operating system. It is recommended that you backup your operating system and files, including the registry, before proceeding. Consult with a qualified computer systems professional, if necessary.

Esri cannot guarantee results from incorrect modifications while following these instructions; therefore, use caution and proceed at your own risk.

Procedure:
  • Regsvr32.exe method:
  1. Open Windows Explorer and use the Find tool to search for regsvr32.exe.
  2. Drag the DLL to regsvr32.exe.
  • Right-click register method:
  1. Open Windows Explorer and navigate to arcgis > arcexe81 > ArcObjects Developer Kit > Utilities.
  2. Double-click register_in_menu.reg. This adds registration tools to the right-click menu.
  3. Right-click the DLL and select Register.

Related Information