English

FAQ: Will ArcSDE work with Oracle patches?

Question

Will ArcSDE work with Oracle patches?

Answer

At ESRI, after the final version of the Oracle database is certified, patches are only added in-house when there is a need to do so. After it is determined that the Oracle patches are needed, users are advised that it would be in their best interest to add them as well.

The recommended way to set up is to install and test the final release version of Oracle (i.e., 8.1.7.0.0), then apply the patch after creating backups of the database. Then, for example, if ArcSDE works at version 8.1.7.0.0 but stops working after applying the Oracle patch, the cause of the problem is known. The Oracle patch must be removed in order for ArcSDE to start functioning again, and the user can contact their Oracle representative to get help on the problem with the Oracle patch.

Related Information