English

Error: Element update failed

Error Message

While editing annotation, the following error message may occur:

"Element update failed".

Cause

The annotation feature class being edited is not supported in earlier versions of the ArcGIS geodatabase.

If editing an 8.1 version geodatabase with ArcGIS 8.2 or ArcGIS 8.3, making certain edits to annotation is not permitted.

If editing an 8.3 or earlier version geodatabase with ArcGIS 9.0 or later, making edits to annotation is not permitted.

If editing Geodatabase annotation with ArcGIS 8.2 is desired, the annotation must be stored in a version 8.2 Geodatabase. With ArcGIS 8.3, annotation in both 8.2 and 8.3 Geodatabases may be edited.

If editing Geodatabase annotation with ArcGIS 9.0 or later is desired, the annotation must be stored in at least a version 9.0 Geodatabase.

Solution or Workaround

Upgrade the personal geodatabase so that the geodatabase version matches the ArcGIS version being used.

For more information on how to upgrade a geodatabase, open the ArcGIS Desktop help, search for the 'upgrading your geodatabase to 8.x' topic, and select the topic from the list.

Warning:
If the geodatabase is updated to the current version, any of the data with an earlier version of ArcGIS will no longer be viewable.