English

How To: Print the symbol and palettes that are associated with ArcMap

Summary

Instructions provided are steps to print the color and symbol palettes that are associated with ArcMap. This process is otherwise known as a StyleDump.

Procedure

To dump symbols or colors, it is necessary to load a sample development script. Perform the following steps only once.

  1. Open an empty MXD file in ArcMap.
  2. Navigate to Tools > Customize.
  3. Select the Commands tab.
  4. Click 'Add from File...'.
  5. Navigate to the Style Dump directory.

    · ArcGIS 9.x:
    Download the sample from the ESRI Developer Network. See the link in the Related Information section below.

    · ArcGIS 8.2 & 8.3:
    <drive>:\arcgis\arcexe8x\ArcObjects Developer Kit\Samples\ArcMap\Styles\Style Dump

    · ArcGIS 8.1:
    <drive>:\arcgis\arcexe81\ArcObjects Developer Kit\Samples\ArcMap\Symbology\Symbols\Style Dump
  6. Select StyleDump.dll. Click Open.
  7. The Developer Samples category appears on the Commands tab.
  8. Drag the StyleDump command from the dialog box to a place on one of the toolbars.
  9. To print sample symbols or colors:

    A. Click Layout View.
    B. Click the Style Dump button.
    C. Select the Symbol Type.
    D. Clicking Display places the symbols in the layout.

    Note:
    To dump symbols from another style, activate a different style through the Style Manager.

  10. Navigate to File > Print to print the selected palette.

    Note:
    Change the size of the layout by navigating to File > Page Setup.

Related Information