ERROR

The version could not be reconciled. Inconsistency with network elements

Last Published: November 25, 2020

Error Message

When reconciling a version on a Geometric Network, the following error can occur:

Error:
The version could not be reconciled. Inconsistency with the network element (ClassID=###, FeatureID=###)
Note:
This article pertains to ArcGIS versions 8.x and 9.x. Later versions of ArcGIS may contain different functionality, as well as different names and locations for menus, commands and geoprocessing tools.

Cause

There is an inconsistency with the network elements of the features being reconciled. These inconsistencies reside within the replica version. The inconsistencies may be due to:

  • An element in the logical network which does not correspond to a feature in the geometric network
  • A feature in the geometric network may have inconsistent connectivity.

Solution or Workaround

Depending on the release of ArcGIS, different steps are necessary to repair network connectivity.

ArcGIS 8.2 or a previous release:

The error may result from two different scenarios. The steps necessary to repair the version can differ slightly for each of the two scenarios. The steps to repair the version assume that the reconcile has failed, the information from the error message has been noted and saved, and the user is in an edit session.

  1. Determine if the feature is in the current version; if not, proceed to Step 2. The error message provides you with the ClassID and FeatureID. The ClassID corresponds to the "ID" field in the GDB_ObjectClasses system table and also the ObjectClassID property on the IObjectClass interface. The FeatureID is the feature's Object ID.

    Zoom to the feature and use the Rebuild Connectivity tool. The area outlined for the Rebuild Connectivity tool should encompass the feature. If it's an edge feature, the outlined area should encompass the junctions located at the end points. Reconcile the version.
  2. If the feature is not located in current version, the error is caused by a phantom EID. A phantom EID is an element whose corresponding feature has been deleted from the geometric network, while the EID has remained within the logical network. The phantom EID must be deleted from the logical network.
  3. Download the attached zip file and extract it. Register the DeleteDescEID.dll on your system. In ArcMap, open the Customize dialog and click Add from File button to add the DLL. The command should be in the Developer Samples folder. Add it to ArcMap.
  4. The Delete Phantom EID command removes phantom elements from the logical network. Read the ReadMe.doc located in the zip for instructions on how to use the sample. After the Phantom EID has been removed, run the Reconcile again.
  5. If, after completing the above steps, you receive the error message upon reconciling the version with its original, or the Delete Phantom EID command cannot find an EID to remove, contact Technical Support.

ArcGIS 8.3 and later versions:

The steps to repair the version assume that the reconcile has failed, the information from the error message has been noted and saved and you are in an edit session.

  1. Open the Network Editing toolbar. This can be done by selecting the View dropdown > ToolbarsNetwork Editing.
  2. To enable most of the tools/commands on the Network Editing toolbar, select a feature class from the Table of Contents that participates in the network containing the feature identified by the error message. This can be the feature class referenced by the error message.
  3. There are two commands that can be used to correct the connectivity in the version, the Rebuild Connectivity tool and the Repair Connectivity command.

    The Rebuild Connectivity tool operates within a user specified rectangle and rebuilds connectivity based on the current state of features within version. It can be used to repair any local inconsistency between geometry and network connectivity for a small area.

    The Repair Connectivity command operates on the connectivity within the entire network or in the case of SDE, on the connectivity within the current version. It is intended for use on the default version once all child versions have been reconciled and posted to Default.

    All future child versions created from Default will benefit from any network inconsistencies that are repaired.

    Users need to be cautious when running the Repair Connectivity command on the default version while it has outstanding replica versions or when running this command on a replica version - both can result in large numbers of conflicts when merging outstanding versions.
  4. If the feature referenced in the error message from Reconcile is in the current version, the Rebuild Connectivity tool can be used to rebuild the connectivity of the feature. The area outlined for the Rebuild Connectivity tool should encompass the entire feature.
  5. If, after rebuilding the connectivity of the feature, the Reconcile fails, rebuild the connectivity of features edited within the current version. The extent of features edited within the current version can be determined by running the VersionExtent sample from ArcObjects Online, located under Samples > Geodatabase > Versioning.
  6. Additionally, the Verify Network Connectivity command can be used to examine the connectivity of the network in the current version. The command creates a selection set of features with inconsistent connectivity. The command will also indicate if there are any inconsistencies solely contained within the logical network.
  7. If the feature cannot be found within the current version or the Rebuild Connectivity tool is unable to correct the network inconsistencies, then the version will either have to be deleted or the Repair Connectivity command will have to be run on the version. Keep in mind that the Repair Connectivity command may result in large numbers of conflicts when merging subsequent outstanding versions. If you have questions or concerns on this, contact Technical Support.

Article ID:000004752

Software:
  • ArcMap 8 x
  • ArcMap 9 x

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic