English

Error: License not available because of an incorrect version number or expired license

Error Message

License not available appears to the right of an extension when trying to activate that extension in ArcMap or ArcCatalog.

Cause

The license file has either an expired feature or an incorrect version number. For example, the following license file is incorrect if 8.x or 9.x is installed:

Code:
SERVER xxx ESRI_SENTINEL_KEY=37111111 27005
VENDOR ESRI
FEATURE ARC/INFO ESRI 7.21 23-nov-98 1 A1A1A1A1A1A1A1A1A1A1 \
vendor_info="A1A1A1A1A1A1A1A1A1A1" ck=99
FEATURE Arcpress ESRI 6.000 01-jan-00 1 A1A1A1A1A1A1A1A1A1A1
vendor_info="A1A1A1A1A1A1A1A1A1A1" ck=99

A correct 9.x license file should look like this:

Code:
SERVER xxx ESRI_SENTINEL_KEY=37111111 27004
VENDOR ARCGIS
FEATURE ARC/INFO ARCGIS 9.0 01-jan-00 1 A1A1A1A1A1A1A1A1A1A1 \
vendor_info="A1A1A1A1A1A1A1A1A1A1" ck=240
FEATURE Arcpress ARCGIS 9.0 01-jan-00 1 A1A1A1A1A1A1A1A1A1A1 \
vendor_info="A1A1A1A1A1A1A1A1A1A1" ck=240

A correct 8.x license file should look like this:

Code:
SERVER xxx ESRI_SENTINEL_KEY=37111111 27005
VENDOR ESRI
FEATURE ARC/INFO ESRI 8.01 01-jan-00 1 A1A1A1A1A1A1A1A1A1A1 \
vendor_info="A1A1A1A1A1A1A1A1A1A1" ck=99
FEATURE Arcpress ESRI 8.01 01-jan-00 1 A1A1A1A1A1A1A1A1A1A1
vendor_info="A1A1A1A1A1A1A1A1A1A1" ck=99

Solution or Workaround

  1. If any of the features in the license file have either an expired feature or an incorrect version number, contact ESRI Customer Service and request an updated license file. See the link below in Related Information on how to contact ESRI Customer Service.
  2. When the new license file arrives, update the license manager server. See the link in the Related Information section below for updating the license manager and use the second procedure, which deletes all existing .lic files.

Related Information