English

Error: Release 1025 of package version_util found, release 1029 expected

Error Message

When running sdesetupora8i the following error occurs:

"WARNING!! Release 1025 of package version_util found, release 1029 expected.
ERROR in creating system stored procedures.
Error: -88
DBMS error code: 6550
ORA-06550: line 1, column 27:
PLS-00201: identifier 'SDE.DBTUNE_UTIL' must be declared
ORA-06550: line 1, column 7:
PL/SQL: Statement ignored"

Cause

The sdesetupora8i executable was built using version 1029 of the version_util package.

The version_util.sps file is labeled with 1025, which is too old for the executable you are running.

Solution or Workaround

This error can be caused by incorrectly set environment variables or an ArcSDE service that is left running while issuing the sdesetupora8i command. To fix this:

  1. Make sure the SDEHOME environment variable is pointing to the correct location.

  2. Make sure %SDEHOME%/bin is the first ESRI product in the PATH environment variable.

  3. Make sure the ArcSDE server process for the specified instance of Oracle is shut down before running sdesetupora8i.