English

Problem: ArcSDE 8.1 Java API: Can't create a layer with a grid size smaller than the X offset

Description

When creating a new layer, if the spatial index grid size is specified to be less than or equal to the value of the X offset, an error appears:

"The specified coordinate exceeds the valid coordinate range."

Cause

This is a known issue with the 8.1 Java application programming interface (API).

Solution or Workaround

This is a known issue without a work-around at ArcSDE 8.1. Only spatial index grid sizes larger than the X offset value can be used.