PROBLEM

I installed ArcIMS and now I can't log into ArcIMS Administrator using the desktop shortcut

Last Published: April 25, 2020

Description

I installed ArcIMS Administrator I can't log in. It used to immediately prompt me for a new password, now it doesn't. It just asks for an existing password.

Cause

The shortcut to ArcIMS Administrator installed by ArcIMS explicitly hardcodes the path to javaw.exe. Since ArcIMS changed the version of JRE that it requires, the path to javaw.exe changed. So if you copied the ArcIMS Administrator shortcut from a previous installation to your desktop, then when you click it, the old version of javaw will be run, which will result in ArcIMS Administrator coming up as usual, but you not being able to log in.

Solution or Workaround



  1. Navigate to \Winnt\Profiles\All Users\Start Menu\Programs\Esri\ArcIMS3.1 on Windows NT or, on Windows 2000, \Documents and Settings\All Users\Start Menu\ProgramsESRI\ArcIMS3.1.
  2. Right-click ArcIMS Administrator and choose Properties.
  3. Click the Shortcut tab.
  4. Change the Target entry to
    "<drive>:\Program Files\JavaSoft\JRE\1.3.0_02\bin\javaw.exe"
    com.esri.aims.admin.console.AdminMain

Article ID:000003436

Software:
  • Legacy Products

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Discover more on this topic