PROBLEM

Cannot unregister a workspace extension if the extension is not installed on the client machine

Last Published: April 25, 2020

Description

To retrieve the IWorkspaceExtensionManager interface to unregister a workspace extension, first open the Workspace. This is not possible if a workspace extension is not installed on the client machine.

Cause

It is by design that a Workspace cannot be opened if the required workspace extensions are not installed on the client machine. Currently, however, the only way to unregister an extension is to open the Workspace to get the IWorkspaceExtensionManager interface.

Solution or Workaround



  1. Register the workspace extension on the client machine.
  2. Open the Workspace and call the method IWorkspaceExtensionManager.UnRegisterExtension.

Article ID:000003057

Software:
  • ArcMap

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