PROBLEM

Unable to preview certain FoxPro tables in ArcCatalog using an OLE DB connection

Last Published: April 25, 2020

Description

Some of the tables can't be previewed after the OLE DB connection is made in ArcCatalog using the OLE DB provider for ODBC sources and the Microsoft Visual FoxPro driver. The field names are listed in the preview window but no rows are visible.

Cause

If the FoxPro table includes a memo field, the data in the table will not display correctly. This is a known issue using the Microsoft OLE DB provider for ODBC sources.

Solution or Workaround

Try one of these workarounds:

  • Export the table to dBASE(IV) format.
  • If the connection is to a FoxPro database, create a view of the table without the memo field.

Article ID:000002703

Software:
  • ArcMap 8 x

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Discover more on this topic