English

Error: ArcIMS3.0 is installed, remove first...

Error Message

When installing ArcIMS or ArcExplorer 3.1 on Microsoft Windows NT or Windows 2000 the following messages may occur:

"ArcIMS3.0 is installed, remove first... " or

"ArcExplorer3.0 is installed, remove first.."

Cause

ArcIMS 3.0 and 3.1 (ArcIMS or ArcExplorer-Java Edition) cannot be installed on the same computer. The 3.1 Windows setup will detect if 3.0 is installed. If it is, a message will display and the install must be cancelled.

Solution or Workaround

Warning:
The instructions below include making changes to essential parts of your operating system. It is recommended that you backup your operating system and files, including the registry, before proceeding. Consult with a qualified computer systems professional, if necessary.

Esri cannot guarantee results from incorrect modifications while following these instructions; therefore, use caution and proceed at your own risk.

Uninstall ArcIMS 3.0

See: How To: Uninstall ArcIMS 3.0 (and ArcExplorer-Java 3.0). If ArcIMS 3.0 and ArcExplorer-Java 3.0 were not uninstalled using the Add/Remove Programs utility, they must be removed them from the registry:
  1. Click Start >Programs > Command Prompt, and type regedit.
  2. In the registry, go to:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall
  3. Delete the ArcIMS 3.0 and ArcExplorer Java 3.0 keys. This removes the entries in the Add\Remove dialog.
Warning:
This should be done by a system administrator.