English

Error: Failed to connect to database Unable to create logfile system tables

Error Message

The following error message is returned when attempting to connect to ArcSDE in ArcGIS:

"Failed to connect to database
Unable to create logfile system tables. User perhaps lacks permission or
resources to create tables."

From an ArcSDE administration tool, the error will look like the following:

"Error: Unable to create logfile system tables. User perhaps lacks permissions or
resources to create tables (-288).
Error: Could not create a connection."

The ArcSDE error log will contain a message similar to the following:

"Error (-288):Couldn't Start Server Task."

Cause

There are various causes, which are addressed below.

1. Another user attempted to connect to SDE using the same login as another user.

2. The user does not have 'create table' nor 'create index' privileges.

3. There is not enough space in the default tablespace of the user or tablespace designated for log files (via the dbtune.sde file).

4. There is not enough quota space in the default tablespace of the user or tablespace designated for log files (via the dbtune.sde file).

Solution or Workaround

  1. Use one login per user, so that this conflict (log file tables are created using the login name and a time stamp) does not occur.
  2. Grant create table and create index permissions. This is required even if the user has READ-ONLY access to SDE, or SDE is set to be READ-ONLY.
  3. Increase available tablespace.
  4. Increase the tablespace quota for the user.