English

Error: Export file is not compatible with layer

Error Message

This error occurs when running sdeimport to load an exported layer into a dataset that has a different extent:

"Export file is not compatible with layer."

Cause

An ArcSDE layer or feature class, exported with 'sdeexport -o create', can only be imported into a dataset that has exactly the same extent.

Solution or Workaround

As a work-around, export the feature class into a shapefile instead of using the ArcSDE sdeexport command. Then, import the shapefile into the dataset that has a different extent.