English

Error: No execute privilege for required Oracle builtin package DBMS_PIPE

Error Message

On a machine running Windows NT 4.0 with Service Pack 6a, and Oracle 8.1.6, this error occurs when starting ArcSDE 8.1 Beta 2 for the first time:

Starting ArcSDE 8.1
Received the following in sde.errlog:

-------------------------------------------------------
ArcSDE 8.1 for Oracle8i Build 586 Thu Aug 24 09:26:13 PDT 2000
-------------------------------------------------------
DBMS Connection established...
No execute privilege for required Oracle builtin package DBMS_PIPE.
ERROR: Cannot Initialize Shared Memory (-404)

Cause

ArcSDE user has inadequate permissions.

Solution or Workaround

Grant the following permissions to your ArcSDE user:

A. Select any table
B. Create any sequence
C. Create any procedure
D. Drop any procedure
E. Execute any procedure