English

How To: Create an area field for a polygon shapefile

Summary

Instructions provided show how to add an area field to a polygon theme attribute table by creating an empty number field and then populating the field using the Field Calculator.

Procedure

  1. Create a new number field in the attribute table of the polygon theme.
    1. Open the table and select Start Editing from the Table menu.
    2. Select Add Field from the Edit menu.
    3. In the Field Definition dialog box:
      1. Set Name to an appropriate name, for example 'Area'.
      2. Set Type to Number.
      3. Set Width to an appropriate number, for example '32'.
      4. Set Decimal Places to the desired number, for example '6'.
      5. Click OK.
    4. Select Stop Editing from the Table menu and save the edits.
  2. Populate the new field with area values.
    Note:
    ArcView calculates the area in the same units used to store the polygons in the shapefile.
    Note:
    To calculate the perimeter use the following expression:
    Code:
    [Shape].ReturnLength
    1. Open the table and Start Editing if necessary.
    2. Make the area field active.
    3. Select Calculate from the Field menu.
    4. Double-click Shape from the Fields category.
    5. Type .ReturnArea in the expression box after [Shape].
      The final expression should look similar to this:
    Code:
    [Shape].ReturnArea
    1. Click OK.
    2. Select Stop Editing from the Table menu and save the edits.