ERROR

Vendor Daemon cannot talk to lmgrd

Last Published: April 26, 2020

Error Message

(ESRI) Vendor daemon cannot talk to lmgrd (Cannot connect to license server
(-15,11:10060) WinSock error code). Vendor daemon died with status 241.
Since this is an unknown status, lmgrd will attempt to re-start the vendor daemon. Restarted ESRI.
(this message is repeated several times.)

Cause

The IP address is incorrect or irresolvable.

Solution or Workaround

 
  1. Verify TCP/IP is working correctly

    Summary:
    The ArcGIS License Manager requires the installation of TCP/IP and a network card.

    Procedure:
     
    1. Click Start > Programs > Accessories > Command Prompt. Type 'hostname' to return the name of the system:
       
      Code:
      c:\> hostname
      server1
      In this example, the hostname is 'server1'. If the hostname command returns anything other than the machine's hostname, the TCP/IP may need to be installed or reinstalled. Contact a Network Administrator for assistance.
    2. Type 'ipconfig' to return the IP address of the system.
       
      Code:
      c:\> ipconfig
      
      Windows NT IP Configuration
      
      Ethernet adapter El90x1:
      
      		IP Address . . . . . . . : 198.102.62.22
      		Subnet Mask. . . . . . . : 255.255.255.0
      		Default Gateway. . . . . : 198.102.62.25
      
      Look at the 'IP Address' line for the current IP address of the computer.
    3. Ping the hostname as returned in step 1.
       
      Code:
      c:\> ping server1
      
      Pinging server1 [198.102.62.22] with 32 bytes of data:
      
      Reply from 198.102.62.22: bytes=32 time<10ms TTL=128
      Reply from 198.102.62.22: bytes=32 time<10ms TTL=128
      Reply from 198.102.62.22: bytes=32 time<10ms TTL=128
      Reply from 198.102.62.22: bytes=32 time<10ms TTL=128
      
      If the IP address returned by step 2 matches the IP Address returned by the ping command, the local TCP/IP name resolution is set up and functioning properly.

      If the IP address returned by step 2 does not match the IP Address returned by the ping command, then name resolution for the system's hostname is incorrect. Contact a Network Administrator to correct the problem.
    4. If ArcGIS is attempting to check out licenses from a remote license manager, execute the ipconfig and ping commands on both the server and the workstation. In this example, the hostnames are workstation1 and server1.

      Run these commands while on the workstation:
       
      Code:
      c:\> ipconfig
      c:\> ping workstation1
      c:\> ping server1
      
      Run these commands while on the license server:
       
      Code:
      c:\> ipconfig
      c:\> ping server1
      c:\> ping workstation1
      
      The IP address for the workstation should be identical when ping is performed on the workstation and the server. This is also true for the server. If a command returns a different IP address for a particular machine, TCP/IP is not functioning properly. Contact a System Administrator.
  2. Verify the IP address is valid. The IP address should not contain 0, 127, or 255; these numbers are reserved. The Subnet Mask will, however, use 0 and 255 in its address. If the IP address is not valid, contact your Systems Administrator.

Article ID:000001944

Software:
  • Legacy Products
  • ArcMap 8 x

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Discover more on this topic