English

Bug: When accessing Portal for ArcGIS 10.4 in Internet Explorer (IE) 11, enabling Compatibility View in the browser displays a runtime error

Description

When accessing Portal for ArcGIS 10.4 in Internet Explorer (IE) 11, enabling Compatibility View in the browser causes IE to display a runtime error when accessing the main links at the top of the page, such as Gallery, My Content, and so on. This issue only happens when using the ArcGIS Web Adaptor.

Cause

The compatibility version details are missing from the web adaptor's web.config file.

Workaround

Update the web adaptor's web.config file as follows:

<system.webServer>
<httpProtocol>
<customHeaders>
<clear />
<add name="X-UA-Compatible" value="IE=11" />
</customHeaders>
</httpProtocol>
<system.webServer>