Knowledge Base - Technical Articles


Technical Article   Error:  Error: Feature ARC/INFO is untrusted

Article ID: 39552
Software:  ArcGIS - ArcEditor 10 ArcGIS - ArcInfo 10 ArcGIS - ArcView 10
Platforms:  Windows XP, Server 2003, Vista, Server 2008, Windows 7

Error Message

This error message occurs when the FlexNet Publisher licensing Trusted Storage File (TSF) components become corrupted. The TSF encrypted file and a configuration XML file holds activation details for both single-use and concurrent-use licensed products protected by Flexera's (Macrovision) FlexNet Publisher licensing suite.

The following are similar error messages that relate to this same issue:

"The ArcGIS Server Administrator has detected that your licenses have become untrusted. This can occur when a machine hardware configuration has changed or licenses have been restored from a backup. Please click the 'Repair' button below to repair your untrusted licenses."

"Error repairing fulfillment (FID-xxxxxxxxxx) with license server (xxxxxx)."

Cause

The FlexNet Publisher licensing Trusted Storage File (TSF) components have become corrupted.

The TSF encrypted file and the XML configuration file holds activation details for both single-use and concurrent-use licensed products.

Solution or Workaround

There are two options available. Try to repair the Trusted Storage and if it cannot be repaired then either delete or rename the Trusted Storage files and re-authorize the software.

Solution 1: Repair Trusted Storage

If the Trusted Storage is in an 'untrusted state' the Trusted Storage must be repaired. Each license is allotted a set number of two repairs per year.

If the Trusted Storage model becomes untrusted, a warning is received when launching ArcGIS Administrator or ArcGIS License Manager that the trusted storage is in need of a repair.

The Trusted Storage repair can be completed by selecting the Repair button within the ArcGIS Administrator, ArcGIS License Administrator, or by de-authorizing and re-authorizing the licenses.

If the repair is not available, then the Trusted Storage can be either deleted or renamed (Solution 2).

Solution 2: Delete or rename Trusted Storage files

Navigate to the Trusted Storage:

• Windows XP & 2003 Server:
C:\Documents and Settings\All Users\Application Data\FLEXnet

• Windows Vista, 2008 Server & 7:
C:\ProgramData\FlexNet

• Unix/Linux:
/usr/local/share/macrovision/storage

1. Delete the Trusted Storage; delete the 'ArcGIS_xxxxxxxx_tsf.data' file within the FlexNet folder.

2. Delete the 'fnp_registrations.xml' file located in the following path:
C:\Program Files\Common Files\Macrovision Shared\FLEXnet Publisher

3. Re-authorize the software.



Related Information


Created: 11/8/2011
Last Modified: 1/24/2012

Article Rating: (2)
If you would like to post a comment, please login

Comments

By vsfoote - 04/28/2013 8:49 AM

The article needs to be updated.

Step 2, to delete fnp_registrations.xml is NOT a correct action because it will impact other FLEXnet Publisher Trusted Storage dependent applications. Correct action is to retain the configuration file and simply the edit the fnp_registrations.xml to delete only the ARCGIS Publisher stanzas: ARCGIS ARCGIS CITYENG

Rating:

By nicktemendez@yahoo.com - 03/12/2013 10:13 PM

The article is incorrect or the solution didn’t work.

Rating: