Knowledge Base - Technical Articles


Technical Article   Bug:  Internet Explorer Script Errors are generated when running any Geoprocessing tool from ArcToolbox on some systems that implement Folder Redirection

Article ID: 38099
Bug Id: NIM011135
Software:  ArcGIS - ArcEditor 9.2, 9.3, 9.3.1, 10 ArcGIS - ArcInfo 9.2, 9.3, 9.3.1, 10 ArcGIS - ArcView 9.2, 9.3, 9.3.1, 10
Platforms:  Windows 2000, XP, Server 2003, Vista, Server 2008, Windows 7

Description

On some systems that implement Folder Redirection and Roaming Profiles, an Internet Explorer Script error is generated when running any Geoprocessing tool in ArcToolbox. The error is similar to the screen shot below:



[O-Image]

The error usually appears three times, then the tool opens successfully.

Cause

This is a known issue. Until a permanent solution is implemented, use the following workaround.

 If similar error messages are being returned but Folder Redirection or Roaming Profiles are not being implemented, see Esri Knowledge Base article 33792 in the Related Information section below.


Workaround

  • For version 9.x and earlier, use the following steps.

    1. Close ArcMap and ArcCatalog.

    2. Download the following compressed ZIP file: ver9x.zip.

    3. There are two files in the ZIP file: MdDlgContent.xsl and MdDlgHelp.xsl. Unzip the contents of the ZIP file to the desktop or a desired location on the hard drive.

    4. In Windows Explorer, navigate to the Stylesheets folder in the ArcGIS installation folder. This is usually located at:

    C:\Program Files\ArcGIS\ArcToolbox\Stylesheets


    5. In the Stylesheets folder, rename MdDlgContent.xsl to MdDlgContent.xsl_old and rename MdDlgHelp.xsl to MdDlgHelp.xsl_old.

    6. Copy the two new files that were extracted from the ZIP file to the Stylesheets folder. The contents of the folder should look like the screen shot below.

    The GP tools should now open without error.


    [O-Image]
  • For version 10, use the following steps.

    1. Close ArcMap and ArcCatalog.

    2. Download the following compressed ZIP file: ver10.zip.

    3. There are two files in the ZIP file: MdDlgContent.xsl and MdDlgHelp.xsl. Unzip the contents of the ZIP file to the desktop or a desired location on the hard drive.

    4. In Windows Explorer, navigate to the Stylesheets folder in the ArcGIS installation folder. This is usually located at:

    C:\Program Files\ArcGIS\Desktop10.0\ArcToolbox\Stylesheets


    5. In the Stylesheets folder, rename MdDlgContent.xsl to MdDlgContent.xsl_old and rename MdDlgHelp.xsl to MdDlgHelp.xsl_old.

    6. Copy the two new files that were extracted from the ZIP file to the Stylesheets folder. The contents of the folder should look like the screen shot below.

    The GP tools should now open without error.


    [O-Image]

Related Information


Created: 8/4/2010
Last Modified: 7/20/2012

Article Rating: (12)
If you would like to post a comment, please login

Comments

By Cne9999 - 03/20/2014 1:26 PM

The article needs to be updated.

Hello, The product uses HTML documents served locally. I fixed this error by adding the local domain (Literally 'Local') to the trusted sites list in the Internet Explorer settings. Add this key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Domains\localhost Add a "D-Word (32-bit) Value" Name: http Value: 1 This works for my installation. All functions work as expected now. Windows 7 x64, IE9, Novell, ArcGIS Desktop 10, v10.0.4400 (SP5). I hope this helps.

Rating:

By msps44 - 01/20/2014 12:40 PM

The article is incorrect or the solution didn’t work.

I am running Win7 Professional on a 64bit machine; this did not work (and the files in question are in a folder called Program Files (x86) for us--is software unable to find them?)

Rating:

By CurtHarvey - 01/18/2013 3:23 PM

I would like to see a new article that discusses the topic outlined below.

Yea well...I did that once and it worked. The issue returned and had to do it again. This article doesn't offer a permanent solution

Rating:

By jschmidt4 - 10/15/2012 12:29 PM

The article is incorrect or the solution didn’t work.

This is extremely frustrating. I am spending lots of money and time to learn how to use ESRI products as a professional. I see this bug has been an issue for awhile. We need to have better resources available to us in resolving difficulty issues if we are expected to utilize your product in the real world.

Rating:

By GISBGE - 09/11/2012 7:28 AM

Great article! It helped a lot!

I'm running ArcVeiw 10 SP4 & recently upgraded IE from 6 to 8 & those really annoying script errors started. This worked perfectly Thank you!

Rating:

By KerryATM - 05/02/2012 7:12 AM

The article is incorrect or the solution didn’t work.

When delivering training this flaw is setting students back severely, this solution does not work.

Rating:

By rich6626 - 01/06/2012 3:03 PM

Other - See details below.

This article has been updated.

By FLLTKaren - 06/30/2011 2:02 PM

Great article! It helped a lot!

Thank you ESRI tech support. What a relief to have those annoying error messages gone and the program running smoothly again. Finally, then end of a giant headache.

Rating:

By graeme - 05/30/2011 9:20 PM

Other - See details below.

Cross referencing a forum discussion that appears to relate to this same issue that persists for me at ArcGIS Desktop 10 SP2 on Vista SP2 and also seen it manifest itself on about 40% of 50 or so XP machines under my supervision over past 6 months. http://forums.arcgis.com/threads/13088-Running-tools-from-Search-window-gives-Webpage-Error-on-some-machines?p=106115#post106115 Disappointed that the writer of this article did not notify people in that thread of this workaround but maybe their searches failed to find it.

Rating:

By Anonymous - 05/11/2011 4:26 PM

The article needs to be updated.

The solution worked perfectly.

Rating:

By Anonymous - 04/21/2011 11:36 PM

The article contains a dead link.

I can also confirm that this did not solve the issue. I'm running student edition of arcinfo 10 on win 7 64bit.

Rating:

By Anonymous - 04/03/2011 7:37 PM

I would like to see a new article that discusses the topic outlined below.

I agree with Bill. The solution in this article did not work. Every time I teach an ESRI course using geoprocessing tools, my students get this script error. Very disruptive as I have to advise them to save their MXD all the time. ESRI, please provide a solution as soon as possible.

Rating:

By Anonymous - 03/17/2011 10:13 AM

The article contains a dead link.

The error referenced in this article is NOT resolved by replacing the specified files. This issue is very disruptive when teaching a class of new ArcGIS users. It presents the application in a very negative light and ESRI should determine exactly what is causing it and engineer a solution.

Rating: