Knowledge Base - Technical Articles
Bug: Upgrading geodatabases with replicas to version 10 causes the synchronization process to fail
| Article ID: | 37896 |
|---|---|
| Bug Id: | NIM058231 |
| Software: | ArcSDE 10 |
| Platforms: | N/A |
Description
This bug affects ArcGIS 10 customers who use geodatabase replication, including checkout replicas from an Enterprise (ArcSDE) Geodatabase, and have either already upgraded their geodatabase to version 10 or are planning on upgrading their geodatabase to version 10. A serious issue has been found that can cause data corruption and other errors when synchronizing replicas to an Enterprise (ArcSDE) Geodatabase.
If an upgrade to version 10 has already been installed, we recommend not synchronizing existing replicas or creating new replicas in the upgraded database until you have applied the patch below.
If an upgrade to version 10 has not been installed, we recommend proceeding with the upgrade but not synchronizing existing replicas or creating new replicas in the upgraded database until you have applied the patch below.
This issue does not apply to:
Cases where the only replicas contained in the upgraded geodatabase are new replicas created using ArcGIS 10
New geodatabases created using ArcGIS 10
Using ArcGIS 10 clients to work with replicas in 9.3.1 or earlier ArcSDE geodatabases
Checkout replicas from Personal and File Geodatabases
Cause
Upgrading a geodatabase with replicas created at version 9.x or version 10.0 pre-release to 10 final causes the synchronization process to fail.
The following issues may occur:
Synchronizing pre-existing replicas from earlier releases returns the following error: 'Version not found'.
Synchronizing pre-existing replicas from earlier releases succeed and apply changes incorrectly, potentially corrupting data.
Creating new replicas returns the following error: 'Version already exists'.
Creating new replicas succeed but synchronization eventually starts failing with 'Version already exists'.
The following issues may occur:
Synchronizing pre-existing replicas from earlier releases returns the following error: 'Version not found'.
Synchronizing pre-existing replicas from earlier releases succeed and apply changes incorrectly, potentially corrupting data.
Creating new replicas returns the following error: 'Version already exists'.
Creating new replicas succeed but synchronization eventually starts failing with 'Version already exists'.
Workaround
A mandatory software patch is available and should be applied to all ArcGIS 10 clients (ArcGIS Desktop, ArcGIS Engine, ArcGIS Server) and applied to upgrade the Enterprise (ArcSDE) geodatabase before synchronizing or creating replicas in the 10.0 geodatabase.
Patch available 07/01/10:
ArcGIS 10.0 (Desktop, Engine, Server) Geodatabase Replication Upgrade
Patch available 07/01/10:
ArcGIS 10.0 (Desktop, Engine, Server) Geodatabase Replication Upgrade
Created: 6/16/2010
Last Modified: 3/20/2012
Article Rating:
(1)
Comments
By emg117 - 03/20/2012 9:54 AM
Other - See details below.
Is this post still accurate? Or has this upgrade been incorporated into SP3 and now SP4?
Rating:
By rich6626 - 03/20/2012 3:16 PM
Other - See details below.
This issue has been fixed. Please download and install Service Pack 4.