Knowledge Base - Technical Articles


Technical Article   Error:  Invalid package. Error reading package contents

Article ID: 36929
Software:  ArcGIS - ArcEditor 9.3.1 ArcGIS - ArcInfo 9.3.1 ArcGIS - ArcView 9.3.1
Platforms:  Windows 2000, XP, 2003Server, Vista

Error Message

Clicking 'Add to ArcGIS' on a layer package that is shared to a group that you belong to from the ArcGIS Online Sharing Application results in the following error message:



[O-Image] invalid


 The error message can also be generated when clicking 'Add to ArcGIS' on a corrupt or invalid layer package from the ArcGIS Online Sharing Application.


Cause

This is a known issue for ArcGIS 9.3.1 products.

Solution or Workaround

Download the patch in the Related Information section below to fix the issue.


    Related Information


    Created: 6/24/2009
    Last Modified: 5/3/2011

    Article Rating: (1)
    If you would like to post a comment, please login

    Comments

    By tbacon - 09/20/2012 8:32 AM

    The article is incorrect or the solution didn’t work.

    I was having this problem, found this solution and applied it but it has not fixed the problem. I have XP xp3 and ArcGIS 9.3.1 without any service packs. I found another soluction (http://forums.arcgis.com/threads/14279-Error-Reading-Package-Contents-from-ArcGIS-online) which suggested changing the location to where the packages are unpackaged and that lead to my looking into c:\program files\common\arcgis\bin where I see the ArcGISFileHelper dlls which are version 10. I double checked to make sure I downloaded the correct fix here and I did. So I don't know what is wrong other than the fix does not work.

    Rating: